News: Contact us to upgrade your software!

Author Topic: Analysis time increased with 7.3.37 installation  (Read 6088 times)

martinjb

  • Client
  • **
  • Posts: 16
    •  
Analysis time increased with 7.3.37 installation
« on: October 05, 2017, 09:43:37 AM »
Dear Hypersizer,

I have recently installed 7.3.37 onto my machine to try and take advantage of the Assembly Projects capability. When I tried to run an assembly it seemed to take a significant amount of time to complete the analysis based on previous performance.  Having investigated 7.3.37 on two different machines I get similar analysis times. 

Details of the analysis are as follows -
1 Project
1 Assembly
31 components
7 effective laminates
9 steps 

When I run the analysis it takes 00:30:00+ to complete this one assembly.

My colleague is still running 7.2.22 and we tried running the analysis on his box and it completed in 00:00:50 and gave the same mass results.

Are there any settings that I need to change in the backdoor settings that have changed or is there something that I have missed in the installation of 7.3.37?  Or is there something that I could have done wrong in creating the database that would significantly increase the time to analyse a model?

The previous iteration of the FEM which had 40+ assemblies, 1500+ components, took approximately 30 mins to run through the whole model. The model has been broken up from a large single model to a model that has been multiple include files.  The results of both models have been checked and the same FEA answers have been achieved.

Sorry I will not be able to share the .hdb.

Regards
Martin

James

  • Administrator
  • *****
  • Posts: 271
    •  
Re: Analysis time increased with 7.3.37 installation
« Reply #1 on: October 12, 2017, 07:09:10 AM »
Hi Martin, I believe this has to do with the exhaustive search flag in the backdoor data options.

Open the backdoor data form > Buckling Coefficients tab > Panel buckling energy solution exhaustive search

Set flag = No.

This flag prompts HyperSizer to try more m and n half modes for the energy buckling solution. This will slow the software significantly. It is only necessary for the buckling analysis of curved panels with long aspect ratios (> 15/1).

-James

martinjb

  • Client
  • **
  • Posts: 16
    •  
Re: Analysis time increased with 7.3.37 installation
« Reply #2 on: October 12, 2017, 08:10:21 AM »
Hit the nail on the head.

Thank you - I switched the flag to No and the anlysis took 00:01:10.  Back to a similar time frame to the previous model.

Thanks again

Ruben

  • *
  • Posts: 40
    •  
Re: Analysis time increased with 7.3.37 installation
« Reply #3 on: February 20, 2018, 10:44:52 AM »
Hi James,

Just wondering why the option is on as default if it slows the software down so significantly, or does it only try more m and n modes when the aspect ratio is greater that 15/1?
We're thinking about setting the flag to No in our Template.

Regards,
Ruben

James

  • Administrator
  • *****
  • Posts: 271
    •  
Re: Analysis time increased with 7.3.37 installation
« Reply #4 on: February 20, 2018, 10:54:33 AM »
Ruben,

To play it safe, we set this flag to "yes" by default. However you're right. It only really becomes an issue for panels with high aspect ratio. If you think this doesn't apply to you then you could set it to false. In fact, you may want to run the analytical methods instead. These run much faster and they handle curved panels now.

To activate the analytical buckling methods for curved panels, select the backdoor flag

Misc > "Curved Panels use Flat Panel Buckling" = Yes.

this flag needs to be renamed. It actually means that HyperSizer will use the analytical methods for curved panels. The analytical methods to handle curvature now.. so no additional conservatism.

I hope this is helpful.

-James

James

  • Administrator
  • *****
  • Posts: 271
    •  
Re: Analysis time increased with 7.3.37 installation
« Reply #5 on: February 21, 2018, 10:43:33 AM »
Actually this flag has been set = No by default in v7.3.50 and newer.

-James

ruth.k.ross@spiritaero.com

  • Client
  • **
  • Posts: 1
    •  
Re: Analysis time increased with 7.3.37 installation
« Reply #6 on: October 28, 2020, 10:49:57 AM »
I'm having a rather similar issue to what was originally described.
I have
1 project
2 assemblies
658 components
57 effective laminates.

It was taking 2 hours to run last week, but it suddenly went to about 24 hours to run only 1 of the assemblies.

Any idea why this would've suddenly changed, and how to reduce run-time?

It looks like the exhaustive search flag has already been set as a default to "no".

James

  • Administrator
  • *****
  • Posts: 271
    •  
Re: Analysis time increased with 7.3.37 installation
« Reply #7 on: October 28, 2020, 01:53:14 PM »