News: Need training? HyperSizer Training Videos are available now! Learn more here: https://hypersizer.com/trainingevents/e-learning/

Author Topic: Import, Reimport Memory Problems, File Sharing Lock Count or System Resources Ex  (Read 5525 times)

James

  • Administrator
  • *****
  • Posts: 230
    •  
This error occurs on FEM Import, Reimport, and Remove FEM actions. This has to do with the default amount of resources that Microsoft assigns to the database engine.  For some reason it assigns a very limited amount of resources and that setting causes HyperSizer to return an error when importing large finite element models.
 
If you have access to change your registry (you might need admin privilege), you can work around this problem pretty easily. You have to change the following key:
 
If you are on 32 bit windows (XP or Windows 7), change the following:
 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 4.0
 
change the value of "MaxLocksPerFile" to something like 50000 (decimal).
 
 
If you are on 64 bit windows (XP or 7), you will not see that key at all and you must change the following:
 
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Jet\4.0\Engines\Jet 4.0
 
change the value of "MaxLocksPerFile" to something like 50000 (decimal).


After this, simply stop and restart HyperSizer and you should be able to delete or reimport your FEM without any problem.

Corresponding Application Error Messages: (1) Line #124, Error#3052, File sharing lock count exceeded. Increase Max LocksPerFile registry entry. (2) Line #26, Error #2147188738, Automation error in fmProject::cmdReimportFEM

Login to view attached image of error message
« Last Edit: April 14, 2011, 08:14:47 AM by James »

James

  • Administrator
  • *****
  • Posts: 230
    •  
Alternatively to changing the registry, you can create a new text file and enter the following text:
 
For 32 bit windows (don't include the dashed lines):
-------------
Windows Registry Editor Version 5.00
 
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 4.0]
"MaxLocksPerFile"=dword:0000c350
-------------
 
For 64 bit windows (don't include the dashed lines):
-------------
Windows Registry Editor Version 5.00
 
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Jet\4.0\Engines\Jet 4.0]
"MaxLocksPerFile"=dword:0000c350
-------------
 
Login to download the appropriate .txt file. Remove the Win32/Win64 from the filename. Then save the file as "ChangeMaxLocks.reg".  Then all you have to do is double click the .reg file and the correct data will be entered into the registry for you.

« Last Edit: April 14, 2011, 08:26:07 AM by James »

Ryan

  • Administrator
  • *****
  • Posts: 145
    •  
This issue has been resolved in 7.0.53.

DaveO

  • Client
  • **
  • Posts: 1
    •  
I encountered this same problem (System Resource Exceeded) in version 7.0.53 when selecting 4320 elements in a 177,700 element model for material axis reorientation.  Is the fix the same, noting it occurred at a different command and a version reported as fixed?  I've pasted the error below.

 EventData

   Application HyperSizer: Thread ID: 10972 ,Logged: Application Error in frmFemPick::GetElementInfo () Line #3, Error #3035, System resource exceeded.